Профессия — 1С

Рукопашный бой Карташ

Категории

Горячие клавиши

рубрики: Начинающим | Дата: 28 Январь, 2014

При написании, просмотре, редактировании кода, навигации по пунктам меню 1С значительно ускорить эти процессы позволяют определенные комбинации нажатия на клавиши, так называемые «Горячие клавиши». Сразу скажу, что перечень будет приведен неполный. Только те, которые я использую в своей работе. Поэтому нелишним будет после прочтения этой статьи обратиться к справке 1С, чтобы расширить этот перечень. Список будет разбит на соответствующие разделы в соответствии с функциональным назначением. В основном будут рассмотрены сочетания, применимые при работе в режиме конфигуратора 1С.




При указании сочетаний клавиш будут использоваться латинские символы, хотя при использовании переключать клавиатуру на английский язык конечно же не нужно. Итак приступим.

  • Навигация

    F12 — если установить курсор на место вызова процедуры или функции, то с помощью этой клавиши можно перейти непосредственно к процедуре или функции;

    Ctrl + ] — позволяет из начала логической конструкции перейти в ее конец. Под логическими конструкциями понимаются: Если … КонецЕсли, Для … Цикл … КонецЦикла, Функция … КонецФункции, Процедура … КонецПроцедуры. То есть если курсор у нас спозиционирован на операторе «Если», то после применения данного сочетания, он спозиционируеься на операторе «КонецЕсли». Очень удобно в ситуациях, когда приходится анализировать большие блоки кода;

    Ctrl + [ — позволяет из конца логической конструкции переместиться в ее начало;

    Ctrl + T — при редактировании кода эта комбинация клавиш позволяет переместиться в дерево метаданных конфигурации и спозиционироваться на том объекте, чей код вы сейчас редактируете;

    Alt + F2 — Устанавливает метку на строчке кода (впоследствии можно перемещаться к этой метке). Отображается синим кружком с левой стороны строки. Имя метки не устанавливается. Возможен последовательный обход меток в рамках текущего окна кода;

    F2 — Переход к следующей метке по направлению «вперед» в текущем окне кода;

    Shift + F2 — Переход к следующей метке по направлению «назад» в текущем окне кода;

    Ctrl + F — поиск текста;

    F3 — найти следующий фрагмент текста;

    Shift + F3 — найти предыдущий фрагмент текста;

    Ctrl + Home — переместить курсор в начало текста;

    Ctrl + End — переместить курсор в конец текста;

    Home — переместить курсор в начало текущей строки;

    End — переместить курсор в конец текущей строки;

    Ctrl + «стрелка вправо» — переместить курсор на одно слово вправо;

    Ctrl + «стрелка влево» — переместить курсор на одно слово влево;

  • Работа с окнами

    Alt + Enter — открыть окно свойств. Информация в окне отображается для того элемента который был выделен до нажатия клавиш. Например, это может быть объект конфигурации, ячейка табличного документа, и т.д.;

    Alt + Shift + Enter — открыть окно дополнительных свойств. Используется для просмотра дополнительных свойств объектов конфигурации;

    Shift + Ctrl + Т — открывает окно с шаблонами текста;

    Shift + Ctrl + Z — закрывает окно служебных сообщений;

  • Редактирование текста

    Ctrl + / (на цифровой клавиатуре) — закомментировать выделенный блок текста;

    Shift + Ctrl + / (на цифровой клавиатуре) — раскомментировать выделенный блок текста;

    Ctrl + C — скопировать выделенный текст в буфер;

    Ctrl + V — вставить из буфера;

    Ctrl + C — вырезать выделенный текст в буфер;

  • Выделение текста

    Ctrl + A — выделить все;

    Shift + Ctrl + Home — выделить текст начиная с текущей позиции курсора и до начала текста;

    Shift + Ctrl + End — выделить текст начиная с текущей позиции курсора и до конца текста;

    Shift + Home — выделить текст начиная с текущей позиции курсора и до начала строки;

    Shift + End — выделить текст начиная с текущей позиции курсора и до конца строки;

    Shift + Ctrl + «стрелка вправо» — выделить слово справа от курсора. Удерживая Shift и Ctrl и последовательно нажимая стрелку можно выделять сразу несколько слов;

    Shift + Ctrl + «стрелка влево» — выделить слово слева от курсора;

    Shift + «стрелка вниз» — выделить строку со смещением курсора на одну строчку вниз. Удобно использовать при выделении нескольких строк;

    Shift + «стрелка вверх» — выделить строку со смещением курсора на одну строчку вверх;

  • Отладка

    F7 — обновить конфигурацию;

    F5 — обновляет конфигурацию, открывает новое окно в режиме предприятия и включает режим отладки открытого окна;

    Ctrl + F5 — открывает новое окно в режиме предприятия и включает режим отладки открытого окна без обновления конфигурации;

    F9 — устанавливает точку останова на текущей строке кода в конфигураторе;

    Alt + F9 — открывает окно со списком всех точек останова конфигурации. Из этого окна можно переместиться к любой из них;

    Ниже приведены сочетания клавиш, которые используются в процессе отладки после того как отработала точка останова

    Sift + F9 — открывает окно в котором можно посмотреть значение переменной или результат вычисления какой-либо функции. Переменную или функцию можно предварительно выделить;

    F11 — пошаговая отладка. При каждом нажатии выполняется одна строка кода;

    Shift + F11 — текущая процедура или функция выполняется до конца, происходит выход из нее и отладочный курсор устанавливается на строке следующей за той из которой эта процедура (функция) вызывалась;

    Shift + F10 — код выполняется до текущей позиции курсора;

  • Обсуждение закрыто.

       

2018г. Профессия — 1С. Обмен опытом по программированию в 1С